Integrated Outlook report button not correctly identifying original sender from shared mailbox forwards

Incident Report for OutKept

Identified

Some users using the integrated Outlook report phishing button are experiencing an
issue where the original sender is not correctly recognized when forwarding a
non-simulation email from a shared mailbox. The issue is ongoing and has been
identified. A limited number of users are affected; users reporting from
personal mailboxes or the OutKept addin are not experiencing this behaviour.
Posted May 07, 2026 - 18:13 CEST
This incident affects: Phishing Simulations.